How to fix AOSP keyboard gesture typing in CyanogenMod 12 and 12.1

Gesture typing is super useful and one the things you will miss the most if it somehow does not work. CyanogenMod 12 and 12.1, based on Android 5.0.2 and 5.1.1 respectively, started depending on a variety of Google Apps packages made by third parties instead of providing an official or semi-official package maintained by one of their own devs like in the past. There is now such a package and is published in the official CyanogenMod Wiki.

A few days ago I made a clean install of the latest CyanogenMod 12.1 nightly build in my OnePlus One and I used the latest Gapps package. Everything went fine but the gesture typing in the AOSP keyboard was not working. I tried many things but after looking around I just found that there is a library missing in some installations.

The problem lies in a script within the official Gapps package that does not copy a library file named to the System\lib folder in certain devices. This library is required by the gesture typing feature so if it’s missing you won’t be able to write by swiping over the keys.

AOSP Keyboard Gesture Typing Library

The solution was easy: I just needed to copy the file to the System\lib folder and after rebooting my phone the gesture typing worked again.

If you are having this problem, just copy that file from your Gapps package to your device inside this specific folder and reboot. If you are using the official Gapps, the file is inside the corresponding folder for the architecture of your device. In the case of the OnePlus One and many other popular and current phones, it is located inside the arch\arm\lib folder.

You will need root access and a file explorer that supports root to be able to copy to system folders. My current favorite is Cabinet but you can use the File Manager app included in all CyanogenMod installations.

AOSP Keyboard Gesture Typing Library

I was about to do another clean install and wipe my phone just for the missing gesture typing but as with many tech-related issues, there’s always a solution. We only need some time and patience to find it.